[asterisk-tech] Voicemail Issues

Richard I. North rick.north at emediait.com
Wed Oct 31 09:26:48 SAST 2007


Richard,
Thanks, all the directories have the correct permissions.

Mark,
I can't seem to find anything unusual in the logs...perhaps I'm looking in the wrong files?

Could mpg123 be a cause for anything? Rpm -q mpg123 says that it's not installed. When I phone VoicemailMain, the last error message says "mpg123: no process killed".

Thanks,
Rick

> -----Original Message-----
> From: tech-bounces at asterisk.org.za [mailto:tech-
> bounces at asterisk.org.za] On Behalf Of Richard Ward
> Sent: 30 October 2007 05:56 PM
> To: Asterisk Tech
> Subject: Re: [asterisk-tech] Voicemail Issues
>
>
> Hey Rick,
>
> As a reference (not sure if it will solve anything), the
> default directories used by asterisk (and ones you
> want/need to check the permissions on) are:
>
> /etc/asterisk
> /usr/lib/asterisk/modules
> /var/lib/asterisk
> /var/spool/asterisk
>
> /var/run
> /var/log/asterisk
> /var/log/asterisk/cdr-csv
>
>
> Cheers,
> richard
> On Tue, 30 Oct 2007 17:36:47 +0200
>   "Richard I. North" <rick.north at emediait.com> wrote:
> >
> > Unfortunately the debug only shows the Executing
> >VoiceMailMain app then it disconnects from asterisk.
> >
> > Thanks,
> > Rick
> >
> >> -----Original Message-----
> >> From: tech-bounces at asterisk.org.za [mailto:tech-
> >> bounces at asterisk.org.za] On Behalf Of Mark Coetser
> >> Sent: 30 October 2007 05:10 PM
> >> To: 'Asterisk Tech'
> >> Subject: Re: [asterisk-tech] Voicemail Issues
> >>
> >>
> >> >-----Original Message-----
> >> >From: tech-bounces at asterisk.org.za [mailto:tech-
> >> bounces at asterisk.org.za] On
> >> >Behalf Of Richard I. North
> >> >Sent: 30 October 2007 05:01 PM
> >> >To: Asterisk Tech
> >> >Subject: Re: [asterisk-tech] Voicemail Issues
> >> >
> >> >Hi Mark,
> >> >
> >> >It's definitely not permissions. I've double checked.
> >>There must be
> >> >something telling asterisk to look for the pid in
> >>/var/run but it's in
> >> >/var/run/asterisk
> >> >
> >> >I've changed the value in asterisk.conf to
> >> >
> >> >astrundir => /var/run/asterisk
> >> >
> >> >Everything else works fine except the voicemail. If I
> >>record a
> >> voicemail,
> >> >the wav file is recorded and sent to my email inbox
> >>then asterisk
> >> crashes.
> >> >If I dial VoicemailMain it also crashes. If I record a
> >>message the
> >> error
> >> >also has
> >> >
> >> >Mpg321: No process killed
> >>
> >>
> >> Hi Richard
> >>
> >> The pid file is just used to store the process id when
> >>asterisk starts
> >> so if
> >> that was your problem asterisk wouldn't start at all
> >>using the init
> >> script.
> >>
> >> I would start asterisk, do asterisk -r and set debug 9
> >>and set verbose
> >> 9 and
> >> watch the cli when you hit voicemail/main
> >>
> >> Thank you,
> >>
> >> Mark Adrian Coetser
> >> mark at tux-edo.co.za
> >> http://www.tux-edo.co.za
> >> http://www.tux-voip.co.za
> >> cel: +27 76 527 8789
> >> fax: +27 86 677 4117
> >>
> >> _______________________________________________
> >> asterisk tech mailing list
> >> tech at asterisk.org.za
> >> http://www.asterisk.org.za/mailman/listinfo/tech
> > _______________________________________________
> > asterisk tech mailing list
> > tech at asterisk.org.za
> > http://www.asterisk.org.za/mailman/listinfo/tech
>
> _______________________________________________
> asterisk tech mailing list
> tech at asterisk.org.za
> http://www.asterisk.org.za/mailman/listinfo/tech


More information about the tech mailing list