[asterisk-tech] Flashing a FXO port?

Steve Davies steve at connection-telecom.com
Mon Oct 8 18:14:06 SAST 2007


On 8 Oct 2007, at 12:43, sunbeam at telkomsa.net wrote:

> Sorry to bother again, I know you are all most probably watching  
> your favourite sports, but I am having a problem with sending a  
> Flash signal to a FXO Zap port and wonderred if one of you guys  
> could help me with some guidance.
>
> I have the following setup....  PSTN--Old PBX--Asterisk box. i can  
> get the call to go from the PSTN to the Asterisk via the old PBX,  
> but when I want to send the call back to the old PBX I can not send  
> it there.
>
> In the dial plan I have added the following on the extension I want  
> to dial in the old PBX...
>
> exten=13,1,Flash
> exten=13,2,SendDTMF(13)
> exten=13,3,Hangup
>
> According to all I have read on the web this should work fine. When  
> I try this I get the following scenario...
>
> Call comes in as per normal, when I put the caller on hold, he can  
> hear the music on hold. I can even hear the extension rining on the  
> old PBX, but as soon as the asterisk box executes the Hangup event,  
> the call gets dropped.
>
> I have tried to set the flash value in the zapata.conf file as  
> explained to on the web, but no luck. Can anyone tell me where I  
> can start looking for a solution for this?


Hi Manie,

If you say that the Flash works and you hear the other phone ringing  
etc, then I think you are just missing a step or two.

Probably you need at least a Wait(3) or so after the senddtmf(13).   
Maybe you need to flash again?

What are the steps to do a flash from a physical phone?

Steve



More information about the tech mailing list